Advanced search

Message boards : News : IMPORTANT: Patched Nvidia drivers for Titans and GTX780

Author Message
Profile GDF
Volunteer moderator
Project administrator
Project developer
Project tester
Volunteer developer
Volunteer tester
Project scientist
Send message
Joined: 14 Mar 07
Posts: 1895
Credit: 629,356
RAC: 0
Level
Gly
Scientific publications
watwatwatwatwat
Message 32000 - Posted: 14 Aug 2013 | 9:09:54 UTC
Last modified: 14 Aug 2013 | 18:55:51 UTC

If you have a titan or gtx780 please use these latest drivers from nvidia which fix an important bug.

Titan/780 drivers:
- Linux 325.15 http://bit.ly/13Qq4kf
- Windows 326.41 http://bit.ly/13k1Ajc

gdf

5pot
Send message
Joined: 8 Mar 12
Posts: 411
Credit: 2,083,882,218
RAC: 0
Level
Phe
Scientific publications
watwatwatwatwatwatwatwatwatwatwat
Message 32008 - Posted: 14 Aug 2013 | 12:23:30 UTC

Are people reporting positive results? Mine crashed with these drivers on the beta queue.

Operator
Send message
Joined: 15 May 11
Posts: 108
Credit: 297,176,099
RAC: 0
Level
Asn
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 32009 - Posted: 14 Aug 2013 | 13:32:19 UTC - in response to Message 32008.

Are people reporting positive results? Mine crashed with these drivers on the beta queue.


Mine did too. I have two Titans running those drivers and two WUs failed when I tried them last night (beta queue).

Operator

____________

Profile GDF
Volunteer moderator
Project administrator
Project developer
Project tester
Volunteer developer
Volunteer tester
Project scientist
Send message
Joined: 14 Mar 07
Posts: 1895
Credit: 629,356
RAC: 0
Level
Gly
Scientific publications
watwatwatwatwat
Message 32011 - Posted: 14 Aug 2013 | 18:55:25 UTC - in response to Message 32009.

We have tested the drivers locally and they work fine.
The problem is now in the boinc application, a new beta is now out to test.

gdf

Profile Retvari Zoltan
Avatar
Send message
Joined: 20 Jan 09
Posts: 1844
Credit: 10,686,789,844
RAC: 10,151,546
Level
Trp
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 32012 - Posted: 14 Aug 2013 | 20:13:49 UTC - in response to Message 32011.

We have tested the drivers locally and they work fine.
The problem is now in the boinc application, a new beta is now out to test.

gdf

It's for Linux only at the moment.

HA-SOFT, s.r.o.
Send message
Joined: 3 Oct 11
Posts: 100
Credit: 4,855,582,826
RAC: 0
Level
Arg
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 32013 - Posted: 14 Aug 2013 | 21:33:05 UTC - in response to Message 32011.

Linux and Titan. App runs but in about 70% errors on maximum time exceeded.

5pot
Send message
Joined: 8 Mar 12
Posts: 411
Credit: 2,083,882,218
RAC: 0
Level
Phe
Scientific publications
watwatwatwatwatwatwatwatwatwatwat
Message 32015 - Posted: 14 Aug 2013 | 22:25:11 UTC - in response to Message 32012.
Last modified: 14 Aug 2013 | 22:31:46 UTC

We have tested the drivers locally and they work fine.
The problem is now in the boinc application, a new beta is now out to test.

gdf

It's for Linux only at the moment.


Indeed.

Edit: gdf, are you saying we need boinc 7.2.5 or..... What exactly?

Profile (retired account)
Send message
Joined: 22 Dec 11
Posts: 38
Credit: 28,606,255
RAC: 0
Level
Val
Scientific publications
watwatwatwatwatwatwatwatwatwat
Message 32022 - Posted: 16 Aug 2013 | 15:39:16 UTC

Thanks for your continued work on this issue.

I regret to report that the beta apps are crashing after a few seconds on my GTX Titan on Win 7 64bit SP1.

The nVidia beta driver 326.41 is installed, DP mode was off. The first two results this afternoon were with the current stock client 7.0.64 (64bit):

http://www.gpugrid.net/result.php?resultid=7155372
http://www.gpugrid.net/result.php?resultid=7155381

The last three results were with the new Alpha BOINC client 7.2.11 (64bit):

http://www.gpugrid.net/result.php?resultid=7155437
http://www.gpugrid.net/result.php?resultid=7155463
http://www.gpugrid.net/result.php?resultid=7155465

Profile MJH
Project administrator
Project developer
Project scientist
Send message
Joined: 12 Nov 07
Posts: 696
Credit: 27,266,655
RAC: 0
Level
Val
Scientific publications
watwat
Message 32027 - Posted: 16 Aug 2013 | 18:53:38 UTC

A favour - can someone with 32bit Windows XP have a look for a file called "nvml.dll" on their system, please? If you have it, please PM me.

Ta,

MJH

Richard Haselgrove
Send message
Joined: 11 Jul 09
Posts: 791
Credit: 1,427,941,620
RAC: 1,315,908
Level
Met
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 32028 - Posted: 17 Aug 2013 | 8:27:55 UTC - in response to Message 32027.

A favour - can someone with 32bit Windows XP have a look for a file called "nvml.dll" on their system, please? If you have it, please PM me.

Ta,

MJH

I've had a look round various machines, looking for both the DLL itself and the compressed NVML.DL_ distribution version in the unpacked driver installer folders - as described in this blog:

http://programminggpus.wordpress.com/2012/10/29/missing-nvml-dll-when-running-a-cuda-program/

It's present on both my 64-bit machines - desktop and laptop (using the mobile GPU drivers) - but it is not present in any form on any 32-bit machine: to answer the direct WinXP question, it's not on host 43404: but it's also not on a Win7/32-bit machine which has been running CUDA - with multiple driver updates - for over four years.

Profile MJH
Project administrator
Project developer
Project scientist
Send message
Joined: 12 Nov 07
Posts: 696
Credit: 27,266,655
RAC: 0
Level
Val
Scientific publications
watwat
Message 32029 - Posted: 17 Aug 2013 | 19:23:46 UTC - in response to Message 32028.

Thanks to Richard and everyone else who looked!

MJH

Profile MJH
Project administrator
Project developer
Project scientist
Send message
Joined: 12 Nov 07
Posts: 696
Credit: 27,266,655
RAC: 0
Level
Val
Scientific publications
watwat
Message 32030 - Posted: 17 Aug 2013 | 19:32:03 UTC

There is now a new Windows beta app, 7.01. Please report how it works on 780s and Titans.

petebe
Send message
Joined: 19 Nov 12
Posts: 31
Credit: 1,549,545,867
RAC: 0
Level
His
Scientific publications
watwatwatwatwatwatwatwat
Message 32031 - Posted: 17 Aug 2013 | 23:46:41 UTC

Ran two beta app 7.01 tests on my Titan:


[/url]http://www.gpugrid.net/result.php?resultid=7159781[url]
[/url]http://www.gpugrid.net/result.php?resultid=7159782[url]

both failed instantly.

W7 x64
326.41

Profile MJH
Project administrator
Project developer
Project scientist
Send message
Joined: 12 Nov 07
Posts: 696
Credit: 27,266,655
RAC: 0
Level
Val
Scientific publications
watwat
Message 32032 - Posted: 18 Aug 2013 | 9:22:01 UTC - in response to Message 32031.

Thanks. Updated to 7.02.

MJH

Husu*
Send message
Joined: 25 Mar 09
Posts: 8
Credit: 100,005,181
RAC: 0
Level
Cys
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 32040 - Posted: 18 Aug 2013 | 16:22:24 UTC
Last modified: 18 Aug 2013 | 16:29:31 UTC

I set up my Titan for beta only, got this error:
8/18/2013 7:14:01 PM | GPUGRID | Giving up on download of acemd.702.exe: permanent HTTP error

After that failed, just response:
8/18/2013 7:17:20 PM | GPUGRID | No tasks are available for ACEMD beta version

I'll leave the computer in the beta queue for for now, so it should download wu's when something comes available.

EDIT:

Direct URL for acemd.702.exe download in browser gives:

Forbidden
You don't have permission to access /PS3GRID/download/acemd.702.exe on this server.

Profile MJH
Project administrator
Project developer
Project scientist
Send message
Joined: 12 Nov 07
Posts: 696
Credit: 27,266,655
RAC: 0
Level
Val
Scientific publications
watwat
Message 32042 - Posted: 18 Aug 2013 | 16:37:27 UTC - in response to Message 32040.

Download fixed now

Husu*
Send message
Joined: 25 Mar 09
Posts: 8
Credit: 100,005,181
RAC: 0
Level
Cys
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 32043 - Posted: 18 Aug 2013 | 16:48:01 UTC - in response to Message 32042.

Nope, doesn't seem to work. I can get 701 from the path but not 702, no permission.

Profile MJH
Project administrator
Project developer
Project scientist
Send message
Joined: 12 Nov 07
Posts: 696
Credit: 27,266,655
RAC: 0
Level
Val
Scientific publications
watwat
Message 32044 - Posted: 18 Aug 2013 | 17:03:14 UTC - in response to Message 32043.

Third time lucky.

Husu*
Send message
Joined: 25 Mar 09
Posts: 8
Credit: 100,005,181
RAC: 0
Level
Cys
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 32045 - Posted: 18 Aug 2013 | 17:09:51 UTC - in response to Message 32044.

Thanks, the executable download works now.

The computer is in queue if there will be wu's available, says none available atm. The earlier wu's probably errored out because of the download failure.

petebe
Send message
Joined: 19 Nov 12
Posts: 31
Credit: 1,549,545,867
RAC: 0
Level
His
Scientific publications
watwatwatwatwatwatwatwat
Message 32046 - Posted: 18 Aug 2013 | 17:11:52 UTC

I'm getting "No tasks are available for ACEMD beta version"

Profile MJH
Project administrator
Project developer
Project scientist
Send message
Joined: 12 Nov 07
Posts: 696
Credit: 27,266,655
RAC: 0
Level
Val
Scientific publications
watwat
Message 32048 - Posted: 18 Aug 2013 | 18:02:06 UTC - in response to Message 32046.

Ok, put some WUs on: MJHARVEY-TEST6

5pot
Send message
Joined: 8 Mar 12
Posts: 411
Credit: 2,083,882,218
RAC: 0
Level
Phe
Scientific publications
watwatwatwatwatwatwatwatwatwatwat
Message 32049 - Posted: 18 Aug 2013 | 18:22:54 UTC

Good news, I've had 1 completed task:

<core_client_version>7.0.64</core_client_version>
<![CDATA[
<stderr_txt>
# Time per step (avg over 25000 steps): 1.796 ms
# Approximate elapsed time for entire WU: 44.911 s
13:20:36 (4016): called boinc_finish

</stderr_txt>
]]>

Bad news, the rest crashed in the same manner as before. Load up to about 3 sec, and WU fails.

<core_client_version>7.0.64</core_client_version>
<![CDATA[
<message>
(unknown error) - exit code -1073741819 (0xc0000005)
</message>
<stderr_txt>

Husu*
Send message
Joined: 25 Mar 09
Posts: 8
Credit: 100,005,181
RAC: 0
Level
Cys
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 32050 - Posted: 18 Aug 2013 | 18:27:01 UTC - in response to Message 32048.

I got two test wu's, both crashed after short while, my Titan is on Double Precision mode.

http://www.gpugrid.net/result.php?resultid=7162461
http://www.gpugrid.net/result.php?resultid=7162462

<core_client_version>7.0.64</core_client_version>
<![CDATA[
<message>
(unknown error) - exit code -1073741819 (0xc0000005)
</message>
<stderr_txt>

petebe
Send message
Joined: 19 Nov 12
Posts: 31
Credit: 1,549,545,867
RAC: 0
Level
His
Scientific publications
watwatwatwatwatwatwatwat
Message 32052 - Posted: 18 Aug 2013 | 18:29:01 UTC

No luck here - ran 2-MJHARVEY_TEST6-0-50-RND8302_0
failed immediately

(and a 99-GIANNI_TEST4-40-50-RND2893_7 which also failed)

http://www.gpugrid.net/results.php?hostid=139142

Titan
W7 x64
326.41
BOINC 7.2.5

HA-SOFT, s.r.o.
Send message
Joined: 3 Oct 11
Posts: 100
Credit: 4,855,582,826
RAC: 0
Level
Arg
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 32053 - Posted: 18 Aug 2013 | 18:49:26 UTC - in response to Message 32048.

Ok, put some WUs on: MJHARVEY-TEST6


Ubuntu 12.04 64 bit + Titan

works ok.

5pot
Send message
Joined: 8 Mar 12
Posts: 411
Credit: 2,083,882,218
RAC: 0
Level
Phe
Scientific publications
watwatwatwatwatwatwatwatwatwatwat
Message 32058 - Posted: 18 Aug 2013 | 22:08:01 UTC

Sweet

Husu*
Send message
Joined: 25 Mar 09
Posts: 8
Credit: 100,005,181
RAC: 0
Level
Cys
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 32071 - Posted: 19 Aug 2013 | 21:11:45 UTC

ACEMD beta version v7.03 (cuda42) seems to be working ok, have gotten 3 work units so far all success:

http://www.gpugrid.net/result.php?resultid=7169488
http://www.gpugrid.net/result.php?resultid=7170042
http://www.gpugrid.net/result.php?resultid=7170118

This is with Windows 7 x64 SP1, GTX Titan in Double Precision mode and Nvidia driver: 326.41

Profile Zarck
Send message
Joined: 16 Aug 08
Posts: 135
Credit: 238,817,093
RAC: 6,310
Level
Leu
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 32534 - Posted: 30 Aug 2013 | 9:49:03 UTC - in response to Message 32071.

GeForce nVidia driver 326.98 Dev.

https://developer.nvidia.com/opengl-driver

Ok for my Titan and Windows 8 Pro 64.

@+
*_*



____________

Post to thread

Message boards : News : IMPORTANT: Patched Nvidia drivers for Titans and GTX780