Advanced search

Message boards : Graphics cards (GPUs) : GPU Utilization seems very low with GPUGrid

Author Message
Palamedes
Send message
Joined: 19 Mar 11
Posts: 30
Credit: 89,190,645
RAC: 0
Level
Thr
Scientific publications
watwatwatwatwatwatwatwatwat
Message 20735 - Posted: 20 Mar 2011 | 15:34:17 UTC

Hi Gang,

In my machine I have an nVidia GTX 285 and a GT 240.

I currently have BOINC set to use all GPUS and to report immediately.

Currently the 285 is running a "Long Run" and the 240 is running "ACEMD2:GPU Molecular dynamics..."

My agent is telling me that the 285 is only using 24% of its CPU and my 240 is only using 5%!

I have followed all of the instructions on this site for setting up my system to speed stuff up, but still my GPU utilization seems very low.

I have tested the clock speeds on the cards and they are both high/normal.

And I don't see this when they are crunching on Einstein@, Milkyway@, Docking@..etc.. Just GPUGrid..

Thoughts?

Profile skgiven
Volunteer moderator
Project tester
Volunteer tester
Avatar
Send message
Joined: 23 Apr 09
Posts: 3501
Credit: 876,524,907
RAC: 1,491,926
Level
Glu
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 20736 - Posted: 20 Mar 2011 | 19:11:43 UTC - in response to Message 20735.


My agent is telling me that the 285 is only using 24% of its CPU and my 240 is only using 5%!

I have followed all of the instructions on this site for setting up my system to speed stuff up, but still my GPU utilization seems very low.

Thoughts?


Think you are mixing up your CPU and GPU.

Palamedes
Send message
Joined: 19 Mar 11
Posts: 30
Credit: 89,190,645
RAC: 0
Level
Thr
Scientific publications
watwatwatwatwatwatwatwatwat
Message 20737 - Posted: 20 Mar 2011 | 20:06:51 UTC - in response to Message 20736.

Think you are mixing up your CPU and GPU.


Hrmm.. Well you might be right.. I know the difference between cpu and gpu, but I was assuming the percentage used as indicated by the agent I have was referring to the GPU usage for the WU's on the GPUs.. but it may actually be showing CPU usage, and not have any indication of how much GPU is being used..

Do GPUGrid WU's typically take a lot longer than other grid computer tasks? The log running one said it takes 8-12 hours on the fastest machines so that one I expected to be slow, but the other one seemed even slower and I typically can produce a Milkyway, Einstein or Docking WU in 2 hours or less.. Some as fast as a few minutes..

Profile skgiven
Volunteer moderator
Project tester
Volunteer tester
Avatar
Send message
Joined: 23 Apr 09
Posts: 3501
Credit: 876,524,907
RAC: 1,491,926
Level
Glu
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 20738 - Posted: 20 Mar 2011 | 20:37:03 UTC - in response to Message 20737.

You can use GPUZ to see the % GPU utilization.

GPUGrid tasks are longer than some and shorter than others. Some Lattice and RNA tasks can run for several days and even weeks. Climate tasks typically take weeks to months to complete. At the other extreme some MW, VP and ibercivis tasks take just a few minutes. On high end GPU's tasks take between about 4h and 12h, so I would say they are slightly longer on average.

Palamedes
Send message
Joined: 19 Mar 11
Posts: 30
Credit: 89,190,645
RAC: 0
Level
Thr
Scientific publications
watwatwatwatwatwatwatwatwat
Message 20739 - Posted: 20 Mar 2011 | 20:50:59 UTC - in response to Message 20738.

Thanks for your fast responses Skgiven, I appreciate it..

GPUZ seems to show my GPU's running at about 50% each.. So still not 100%.. Though this is on two Einstein@ tasks..

Also on a side note.. I was running two GPUGrid tasks and paused boinc to restart my machine.. On restarting boinc I had no GPUGrid tasks and my log reports this;

423 GPUGRID 3/20/2011 3:42:18 PM update requested by user
424 GPUGRID 3/20/2011 3:42:22 PM Sending scheduler request: Requested by user.
425 GPUGRID 3/20/2011 3:42:22 PM Not reporting or requesting tasks
426 GPUGRID 3/20/2011 3:42:24 PM Scheduler request completed

Why not requesting tasks?

Palamedes
Send message
Joined: 19 Mar 11
Posts: 30
Credit: 89,190,645
RAC: 0
Level
Thr
Scientific publications
watwatwatwatwatwatwatwatwat
Message 20740 - Posted: 20 Mar 2011 | 20:53:49 UTC - in response to Message 20738.

At the other extreme some MW, VP and ibercivis tasks take just a few minutes.


You aint kidding.. I just had a MW take like 8 minutes..

Profile skgiven
Volunteer moderator
Project tester
Volunteer tester
Avatar
Send message
Joined: 23 Apr 09
Posts: 3501
Credit: 876,524,907
RAC: 1,491,926
Level
Glu
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 20741 - Posted: 20 Mar 2011 | 21:05:20 UTC - in response to Message 20740.

Perhaps you did not get any GPUGrid tasks because you were running other GPU tasks (MW) or other project debt (due to project weightings) was in affect.

Palamedes
Send message
Joined: 19 Mar 11
Posts: 30
Credit: 89,190,645
RAC: 0
Level
Thr
Scientific publications
watwatwatwatwatwatwatwatwat
Message 20742 - Posted: 20 Mar 2011 | 23:05:57 UTC - in response to Message 20741.

Perhaps you did not get any GPUGrid tasks because you were running other GPU tasks (MW) or other project debt (due to project weightings) was in affect.


Ah okay.. I'll have to look that up.. I dont know what project debt is yet..

Thanks bud!

John
Send message
Joined: 27 Jun 09
Posts: 3
Credit: 31,290,058
RAC: 0
Level
Val
Scientific publications
watwatwatwatwatwatwatwatwat
Message 21050 - Posted: 24 Apr 2011 | 20:07:58 UTC - in response to Message 20735.

I was running 50 to 60% on my 2 GTX 260's in SLI. I backed my CPU usage down to max of 70% and now run about 82% on each of my GPU's

Profile [MDX] CJ
Avatar
Send message
Joined: 3 Mar 09
Posts: 18
Credit: 6,044,967
RAC: 0
Level
Ser
Scientific publications
watwatwatwatwatwatwatwatwatwat
Message 21062 - Posted: 26 Apr 2011 | 3:01:21 UTC - in response to Message 21050.

You might want to check out gpu shark. its good at displaying relevant gpu information of all installed gpu's.
____________

Post to thread

Message boards : Graphics cards (GPUs) : GPU Utilization seems very low with GPUGrid