Advanced search

Message boards : Wish list : Mixed GPU support

Author Message
Profile liveonc
Avatar
Send message
Joined: 1 Jan 10
Posts: 292
Credit: 41,567,650
RAC: 0
Level
Val
Scientific publications
watwatwatwatwatwat
Message 16102 - Posted: 31 Mar 2010 | 13:40:29 UTC
Last modified: 31 Mar 2010 | 13:42:15 UTC

I finally built an HTPC, there was a bit of confusion with installing the correct driver but it's working now.

30-03-2010 23:23:52 Starting BOINC client version 6.10.18 for windows_x86_64
30-03-2010 23:23:52 log flags: file_xfer, sched_ops, task
30-03-2010 23:23:52 Libraries: libcurl/7.19.4 OpenSSL/0.9.8l zlib/1.2.3
30-03-2010 23:23:52 Data directory: C:\ProgramData\BOINC
30-03-2010 23:23:52
30-03-2010 23:23:52 Processor: 2 GenuineIntel Intel(R) Pentium(R) Dual CPU E2180 @ 2.00GHz [Intel64 Family 6 Model 15 Stepping 13]
30-03-2010 23:23:52 Processor: 1.00 MB cache
30-03-2010 23:23:52 Processor features: fpu tsc pae nx sse sse2 pni
30-03-2010 23:23:52 OS: Microsoft Windows 7: x64 Edition, (06.01.7600.00)
30-03-2010 23:23:52 Memory: 1.75 GB physical, 3.50 GB virtual
30-03-2010 23:23:52 Disk: 232.79 GB total, 215.59 GB free
30-03-2010 23:23:52 Local time is UTC +2 hours
30-03-2010 23:23:53 NVIDIA GPU 0: GeForce 8800 GT (driver version 19621, CUDA version 3000, compute capability 1.1, 256MB, 336 GFLOPS peak)
30-03-2010 23:23:53 NVIDIA GPU 1: GeForce 9400 (driver version 19621, CUDA version 3000, compute capability 1.1, 256MB, 45 GFLOPS peak)
30-03-2010 23:23:53 Not using a proxy
30-03-2010 23:23:53 GPUGRID URL http://www.gpugrid.net/; Computer ID 67962; resource share 100
30-03-2010 23:23:53 General prefs: from http://boinc.bakerlab.org/rosetta/ (last modified 21-Mar-2010 11:26:16)
30-03-2010 23:23:53 Host location: none
30-03-2010 23:23:53 General prefs: using your defaults
30-03-2010 23:23:53 Reading preferences override file
30-03-2010 23:23:53 Preferences limit memory usage when active to 1611.50MB
30-03-2010 23:23:53 Preferences limit memory usage when idle to 1611.50MB
30-03-2010 23:23:53 Preferences limit disk usage to 0.00GB

But what is shown is http://www.gpugrid.net/show_host_detail.php?hostid=67962

This is ok, for me. It'll miss out on that 24 hour bonus for every 1 out of 4 WU, but that's ok. What isn't ok, is if I used a G200 or GF100 GPU. If anyone mixes their PC's in such a way, they'd get WU's that are unsupported, &/or get errors plus miss 24hour bonus'.

I'm not saying that others will want to build HTPC's, but if anyone uses a PC that has several mixed GPU's, they'll have to take GPU's out or build an extra PC.
____________

Profile skgiven
Volunteer moderator
Project tester
Volunteer tester
Avatar
Send message
Joined: 23 Apr 09
Posts: 3968
Credit: 1,915,496,685
RAC: 112,113
Level
His
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 16307 - Posted: 15 Apr 2010 | 10:47:22 UTC - in response to Message 16102.

This is the card shown (only one online, but both with Boinc)
NVIDIA GeForce 8800 GT (243MB) driver: 19713

Is it running two tasks at a time or just tasks on the 8800GT?

Profile liveonc
Avatar
Send message
Joined: 1 Jan 10
Posts: 292
Credit: 41,567,650
RAC: 0
Level
Val
Scientific publications
watwatwatwatwatwat
Message 16315 - Posted: 15 Apr 2010 | 21:25:19 UTC - in response to Message 16307.

I have temporarily given up on that pc. In the beginning, I got both cards crunching after finally installing the correct GPU drivers needed & setting up the BIOS in the correct way. But all of a sudden, it stopped running altogether & reported that there wasn't enough memory on the GPU. After that, I could only get the 9400 IGP crunching, the 8800GT ALWAYS reported too little memory & even after I tried to reinstall Windows 7, it still wouldn't use both GPU's as it did once. I complained in another thread about this. I don't know what to do about it, run folding@home???
____________

Profile liveonc
Avatar
Send message
Joined: 1 Jan 10
Posts: 292
Credit: 41,567,650
RAC: 0
Level
Val
Scientific publications
watwatwatwatwatwat
Message 16317 - Posted: 16 Apr 2010 | 0:21:32 UTC - in response to Message 16307.
Last modified: 16 Apr 2010 | 0:24:38 UTC

I decided to try again because I wanted to upgrade the CPU anyways. Still doesn't want to, but this time it doesn't complain about lack of memory.

BTW, here's proof that i got it to work once: http://www.gpugrid.net/result.php?resultid=2083487 & http://www.gpugrid.net/result.php?resultid=2075138 It shows also that there are two different GPU's, but when you look here: http://www.gpugrid.net/show_host_detail.php?hostid=68472 you'll see that GPUGRID.net shows [2] NVIDIA GeForce 8800 GT (243MB) driver: 19713
____________

Profile skgiven
Volunteer moderator
Project tester
Volunteer tester
Avatar
Send message
Joined: 23 Apr 09
Posts: 3968
Credit: 1,915,496,685
RAC: 112,113
Level
His
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 16331 - Posted: 16 Apr 2010 | 16:01:29 UTC - in response to Message 16317.
Last modified: 16 Apr 2010 | 16:38:17 UTC

How come it downloaded 9 tasks today?
1 completed, 1 errored and the rest still in progress.

Is it running with the 9400 only?

[2] NVIDIA GeForce 9400 (512MB) driver: 19621

Profile liveonc
Avatar
Send message
Joined: 1 Jan 10
Posts: 292
Credit: 41,567,650
RAC: 0
Level
Val
Scientific publications
watwatwatwatwatwat
Message 16336 - Posted: 16 Apr 2010 | 18:11:34 UTC - in response to Message 16331.

Apparently Nvidia Drivers version 196.21 & before, could detect the correct ammount of memory. That way probably how I got it to work previously. But all of a sudden, it only "detects", but doesn't start the jobs for 256MB GPU cards, so I had to raise the shared memory of the 9400 IGP to 512MB. Now GPUGRID.net gets WU for BOTH the 9400IGP & the 8800GT, but only crunches from the 9400IGP. I must have tried all the BIOS settings & Nvidia drivers 195-196, but still can't get it to work.
____________

Post to thread

Message boards : Wish list : Mixed GPU support